Andrei Paldrom Andrei Paldrom - 5 months ago 99
Linux Question

Conflicts between 'gsl' dependencies in Ubuntu 16.04

I have a problem with importing a module inside python, adressed here, but it seemed that I need to install

libgsl.so.19
library, which is missing and there is no problem with the library path suggested in other posts. The thing is that this library is present in Ubuntu 16.04 in
libgsl2
package. My software requires
libgsl0ldbl
which interferes with
libgsl2
.

Is there any way in Ubuntu 16 that
libgsl0ldbl
can contain
libgsl.so.19
library as well?


cheers!

Answer

Is there any way in Ubuntu 16 that libgsl0ldbl can contain libgsl.so.19 library as well ?

No, but you get a package compat-libgsl2-19_2.1-2_amd64.deb with only /usr/lib/x86_64-linux-gnu/{ libgsl.so.19, libgsl.so.19.0.0 }

Link https://drive.google.com/file/d/0B7S255p3kFXNZXhrWENrOWt3QVU/view?usp=sharing

→ No conflicts with libgsl0ldbl.