Kasper Souren Kasper Souren - 5 months ago 249
Android Question

How to solve "Your APK's version code needs to be higher than 2." in Google Play's Developer Console?

I'm getting this error when uploading my Phonegap app to the Google Play Developer Console:


Your APK's version code needs to be higher than 2.


How can I fix this?

Answer

Use aapt to verify your APK version:

aapt dump badging myapp.apk

It will tell you to increase the versionCode in AndroidManifest.xml, e.g.

  <manifest android:versionCode="3">