Alter Lagos Alter Lagos - 5 months ago 224
Ruby Question

Bundler is removing RUBY VERSION from Gemfile.lock

I'm having the opposite issue to this one. The

Gemfile
has:

source 'https://rubygems.org'
ruby '2.3.1'


At the end of my
Gemfile.lock
file is:

RUBY VERSION
ruby 2.3.1p112

BUNDLED WITH
1.12.4


But when I run
bundle install
is always deleting
RUBY VERSION
regardless I'm using the same as the development team's version. Even I'm using a more recent bundler version than the used to generate the original
Gemfile.lock
file:

$ bundle -v
Bundler version 1.12.5
$ ruby -v
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux]


Any ideas how can I stop this?

Answer

After a couple of days I stumbled upon another problem where I had to run spring stop. After that it started to generate it correctly.
My bad for suspending my pc and have running those processes for weeks instead of trying the good old shutdown.