LeeRQ LeeRQ - 2 months ago 20
Swift Question

sudo gem install cocoa pods --pre error

enter image description here

today I going to use swift 3.0,so I want to use cocoa pods to install Alamofire 4.0,but terminal note that require cocoa pods 1.1.0,my pods is 1.0.1, so I use sudo gem install cocoapods --pre to update, But get errorT.T,by the way, thanks very much

Answer

What the error says is that you can't write to: /usr/bin. Try this and see if it makes any difference:

sudo gem install -n /usr/local/bin cocoapods --pre