sri sri - 3 months ago 17
Linux Question

SendMail Error Message: 553 5.1.8 … Domain of sender address … does not exist

I setup sendmail server with inhmail.walkingtree.in in local

when i tried to sen dmail from other email servers i am getting the following error ,

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

mail1@inhmail.walkingtree.in
SMTP error from remote mail server after MAIL FROM:<srinivasa.nallapati@walkingtree.in> SIZE=2548:
host inhmail.walkingtree.in [122.175.35.121]:
553 5.1.8 <srinivasa.nallapati@walkingtree.in>... Domain of sender address srinivasa.nallapati@walkingtree.in does not exist

------ This is a copy of the message, including all the headers. ------


I installed sendmail server in 192.168.1.145. the domain name of .145 is inhmail.walkingtree.in

i opened port 25 in firewall in system and router as well .

Mail receiving and sending in 192.168.1.0/24 is working fine with @inhmail.walkingtree.in.

Please help that
how sendmail can receive mails from external email servers.


UPADTED

> [srinivas@localhost ~]$ echo "check_mail jd@walkingtree.in" | sendmail -d8.20 -bt
ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
Enter <ruleset> <address>
> check_mail input: jd @ walkingtree . in
Basic_check_mail input: jd @ walkingtree . in
tls_client input: $| MAIL
D input: < > < ? > < ! "TLS_Clt" > < >
D returns: < ? > < > < ? > < ! "TLS_Clt" > < >
A input: < > < ? > < ! "TLS_Clt" > < >
A returns: < > < ? > < ! "TLS_Clt" > < >
TLS_connection input: $| < > < ? > < ! "TLS_Clt" > < >
TLS_connection returns: OK
tls_client returns: OK
CanonAddr input: < jd @ walkingtree . in >
canonify input: < jd @ walkingtree . in >
Canonify2 input: jd < @ walkingtree . in >
dns_getcanonname(walkingtree.in, trymx=1)
dns_getcanonname: trying walkingtree.in. (AAAA)
NO: errno=0, h_errno=4
dns_getcanonname: trying walkingtree.in. (A)
NO: errno=0, h_errno=4
dns_getcanonname: trying walkingtree.in. (MX)
NO: errno=0, h_errno=4
dns_getcanonname: trying walkingtree.in.localdomain (AAAA)
NO: errno=0, h_errno=1
Canonify2 returns: jd < @ walkingtree . in >
canonify returns: jd < @ walkingtree . in >
Parse0 input: jd < @ walkingtree . in >
Parse0 returns: jd < @ walkingtree . in >
CanonAddr returns: jd < @ walkingtree . in >
SearchList input: < + From > $| < F : jd @ walkingtree . in > < U : jd @ > < D : walkingtree . in > < >
F input: < jd @ walkingtree . in > < ? > < + From > < >
F returns: < ? > < >
SearchList input: < + From > $| < U : jd @ > < D : walkingtree . in > < >
U input: < jd @ > < ? > < + From > < >
U returns: < ? > < >
SearchList input: < + From > $| < D : walkingtree . in > < >
D input: < walkingtree . in > < ? > < + From > < >
D input: < in > < ? > < + From > < >
D returns: < ? > < >
D returns: < ? > < >
SearchList returns: < ? >
SearchList returns: < ? >
SearchList returns: < ? >
Basic_check_mail returns: $# error $@ 5 . 1 . 8 $: "553 Domain of sender address " " does not exist"
check_mail returns: $# error $@ 5 . 1 . 8 $: "553 Domain of sender address " " does not exist"
> [srinivas@localhost ~]$


Working:

Yes thanks ,now it is working .

problem is i am unable to ping walkingtree.in ,due to local DNS server settings.I removed dbs server in network connections now i am able to get mails from GMail and walkingtree.in

when i am using dns server , i am able to ping www.walkingtree.in but not walkingtree.in . can you please help me to able to ping walkingtree.in

Answer

You sendmail thinks that envelope sender's domain walkingtree.in does not exist (no MX, A, AAAA DNS records). It refuses to accept messages with such envelope sender because there will be no way to send back (eventual) bounce messages (reports about email delivery problems).

You may use nslookup (or dig) to check if the server sees the DNS records:

nslookup -type=mx walkingtree.in
dig walkingtree.in MX


IF YOU USE SENDMAIL (not postfix) then as root execute the command below to locate the problem:

echo "check_mail jd@walkingtree.in" | sendmail -d8.20 -bt

In case of "Undefined ruleset check_mail" error try:

echo "checkmail jd@walkingtree.in" | sendmail -d8.20 -bt

-d8.20 turns on tracking of DNS queries
checkmail - equivalent of check_mail used with FEATURE(delay_checks)

Comments