in code veritas in code veritas - 5 months ago 26
Python Question

Fortran error when trying to install scipy

I'm trying to install scipy with Pip, using:

sudo pip install scipy


I throw this error, though:

dyld: Library not loaded: /usr/local/lib/libisl.13.dylib

Referenced from: /usr/local/Cellar/gcc/5.1.0/libexec/gcc/x86_64-apple-darwin14.3.0/5.1.0/f951

Reason: image not found

gfortran: internal compiler error: Trace/BPT trap: 5 (program f951)

error: Command "/usr/local/bin/gfortran -Wall -g -ffixed-form -fno-second-underscore -fPIC -O3 -funroll-loops -I/usr/local/lib/python2.7/site-packages/numpy/core/include -c -c /private/tmp/pip-build-WaJ_GP/scipy/scipy/fftpack/src/dfftpack/dcosqb.f -o build/temp.macosx-10.5-x86_64-2.7/private/tmp/pip-build-WaJ_GP/scipy/scipy/fftpack/src/dfftpack/dcosqb.o" failed with exit status 4


When I run:

brew install gcc


I get:

Warning: gcc-5.1.0 already installed


What gives?

Answer

Uninstalling (with --force) and reinstalling dependencies fixed the issue. (gmp, mpfr, libmpc, isl, cloog)

Comments