J. K. J. K. - 1 month ago 11
Android Question

If I bump minSdkVersion from 14 to 15 for the new app version, will users with 14 be able to upgrade to it?

A library that I'm using requires minSdkVersion to be 15.
The app is already published in the store with minSdkVersion 14.

If I bump minSdkVersion from 14 to 15 for the new app version, will users with 14 be able to upgrade to it? Or is it only going to hide it from the Google App Store with users running Android API 14?

Answer

minSdkVersion refer to the minimum version that your application is supported. By upgrading from 14 to 15, any users who are using phone with API level 14(ICS) will not be able to access any apps above 14.