Suhail Mumtaz Awan Suhail Mumtaz Awan - 1 month ago 30
Javascript Question

Bootstrap's JavaScript requires jQuery version 1.9.1 or higher, but lower than version 3

Introduction

I am working with the bootstrap framework.I am currently working on "Bootstrap Tabs"(hide/show).I am using bootstrap version 3 and jquery version 3.0.2 something.

Problem

My tabs are not working, unless i load jquery of version less than 1.6.But then ajax making problem with jquery less than 1.6. Chrome console give me this error.


bootstrap.min.js:6 Uncaught Error: Bootstrap's JavaScript requires
jQuery version 1.9.1 or higher, but lower than version 3


I tried different fallback techniques but couldn't implement correctly.

I am stuck here for 2 days, if someone have any idea or any reference, please do help.Thanks for your time.

Answer

Currently Bootstrap 3.x does not support jQuery 3.x as reported here: https://github.com/twbs/bootstrap/issues/16834

The issue is caused by:

jQuery 3 is more strict than jQuery 2. It's like XHTML and HTML. Backward compatibility is preserved and code doesn't look like a mess. If I'm not mistaken, all you need to do is replace show() and hide() functions with .css('display', '') or addClass('hidden') and fix a selector in alert.js (QUnit fails on this line because $('#') is invalid in jQuery 3)

It must be fixed on the Bootstrap 3.3.7 release: https://github.com/twbs/bootstrap/issues/16834#issuecomment-225039913