Chris Chris - 6 months ago 40
iOS Question

Cydia app installation problems

I have been hosting my app on a cydia repository for quite some time, and haven't had any problems hosting the app for iOS 5 or iOS 6. However, when I upgraded one of my devices to iOS 7, and tried to install the app it gave me some errors during the installation.

The erros I am getting are,

subprocess dpkg-deb --fsys-tarfile returned error exit status 2

Sub-process /usr/bin/dpkg returned an error code (1)


I've tried googling the errors, but haven't had much luck, and I just reread saurik's post about building a .deb file and creating a cydia repository, here I am still not sure why the package / .deb file would work in iOS 6 but then stop working in iOS 7.

I even created a simple test app with just button in it using Xcode 5, and that simple test app is giving me the same errors as stated above.

Answer

Apparently there's some compatibility issues with dpkg, Cydia, and the homebrew release of dpkg. I ended up finding this, which solved the install problem. :)

Comments