cmarti1138 cmarti1138 - 1 month ago 20
Swift Question

why does xcode try to convert googlemap cocoapods frameworks?

I am trying to create a new project with xcode 8 and google maps cocoapods. I have read that their framework is in swift 3.0, but whenever I install the framework on the project and open .xcworspace file and xcode automatically prompts be to convert to 3.0 or 2.3. The project is a newly created project that was created in swift 3.0.

I am running cocoapods 1.0.1. Thank you again for all that respond.

Contents of podfile:

# Uncomment this line to define a global platform for your project
# platform :ios, '9.0'

target 'googleMaps' do
use_frameworks!

pod 'GoogleMaps'
pod 'GooglePlaces'

target 'googleMapsTests' do
inherit! :search_paths
# Pods for testing
end

target 'googleMapsUITests' do
inherit! :search_paths
# Pods for testing
end

end

Answer

I think you need to update cocoapods to pre version 1.1.0.rc.3

Run this command on terminal

sudo gem install cocoapods --pre

Then create a new project and install pod for GoogleMaps. Mine is working fine and Xcode never asks to convert to 2.3.

Running pod --version on termial will return this

Rajan-Maheshwari354:~ rajan$ pod --version
1.1.0.rc.3

If this didn't work, just try pod update

Comments