javacreed javacreed - 3 months ago 51
Ajax Question

Error: cannot call methods on autocomplete prior to initialization; attempted to call method 'destroy'

I am using ajax-solr. It works fine with jquery-ui-1.8.*.

But when I upgrade it to jquery-1.10.* it gives me this exception:


cannot call methods on autocomplete prior to initialization; attempted to call method 'destroy'

Answer

I got the answer to it in the initialization of autocomplete widget...just add

$(this.target).find('input').autocomplete();

This will initialize the autocomplete widget this happened because in 1.10.* .Jquery has added error messages for usage of functions without proper initialization whereas it was not there in previous versions.

Comments