Ringo Blancke Ringo Blancke - 4 months ago 20
Ruby Question

API Signature is required to make requests to PayPal error, I have an API signature set already

I'm having a big problem right now. My site is written in Ruby on Rails, and I'm using the active merchant gem to interface with PayPal. The site is hosted on heroku.

I have an API key and API signature set as config variables in my heroku app. However, I still get the error:

Running: rake assets:precompile
(in /tmp/build_3pvaswdp7wvca1)
rake aborted!
An API Certificate or API Signature is required to make requests to PayPal
(See full trace by running task with --trace)


I can run heroku run rake assets:precompile separately and that works completely fine.

Furthermore, my staging site has the exact same config variables (RACK_ENV and RAILS_ENV are set to production on the staging site btw) set on my staging site and that seems to be working fine. However, my production site crashes.

Any ideas on what might be happening / how to fix this issue?

Answer

I just found out about this command:

heroku labs:enable user-env-compile -a myapp 

BUT it is experimental.

Comments