Jeremy Iglehart Jeremy Iglehart - 3 months ago 128
Node.js Question

New NodeJS Error Thrown While Running mupx deploy

I have no idea why this is happening. I seriously just made a small change (a single character typo to one of my templates) and then my entire deployment blew up and stopped working.

$ mupx deploy

Meteor Up: Production Quality Meteor Deployments
------------------------------------------------
Configuration file : mup.json
Settings file : settings.json

“ Checkout Kadira!
It's the best way to monitor performance of your app.
Visit: https://kadira.io/mup ”

Meteor app path : /Users/jeremy/Documents/clients/MyAppNameDir/MyAppName
Using buildOptions : {}

Started TaskList: Deploy app 'MyAppName' (linux)
[000.000.000.000] - Uploading bundle
[000.000.000.000] - Uploading bundle: SUCCESS
[000.000.000.000] - Sending environment variables
[000.000.000.000] - Sending environment variables: SUCCESS
[000.000.000.000] - Initializing start script
[000.000.000.000] - Initializing start script: SUCCESS
[000.000.000.000] - Invoking deployment process
[000.000.000.000] - Invoking deployment process: SUCCESS
[000.000.000.000] - Verifying deployment
[000.000.000.000] x Verifying deployment: FAILED

-----------------------------------STDERR-----------------------------------
npm -g install npm@latest
npm WARN deprecated
npm WARN deprecated (Depending on how Node.js was installed on your system, you
npm WARN deprecated may need to prefix the preceding commands with `sudo`, or if
npm WARN deprecated on Windows, run them from an Administrator prompt.)
npm WARN deprecated
npm WARN deprecated If you're running the version of npm bundled with
npm WARN deprecated Node.js 0.10 LTS, be aware that the next version of 0.10 LTS
npm WARN deprecated will be bundled with a version of npm@2, which has some small
npm WARN deprecated backwards-incompatible changes made to `npm run-script` and
npm WARN deprecated semver behavior.
npm WARN package.json meteor-dev-bundle@0.0.0 No description
npm WARN package.json meteor-dev-bundle@0.0.0 No repository field.
npm WARN package.json meteor-dev-bundle@0.0.0 No README data

> fibers@1.0.8 install /bundle/bundle/programs/server/node_modules/fibers
> node build.js || nodejs build.js


=> Redeploying previous version of the app

-----------------------------------STDOUT-----------------------------------

To see more logs type 'mup logs --tail=50'

----------------------------------------------------------------------------

22:18:34  ✘  ...clients/MyAppNameDir/MyAppName   ClientSideAddIdea ✔ 
$ mup logs --tail=50
zsh: command not found: mup

22:18:43  ✘  ...clients/MyAppNameDir/MyAppName   ClientSideAddIdea ✔ 
$ mupx logs --tail=50

Meteor Up: Production Quality Meteor Deployments
------------------------------------------------
Configuration file : mup.json
Settings file : settings.json

[000.000.000.000] at Object.<anonymous> (/bundle/bundle/programs/server/node_modules/fibers/fibers.js:16:8)
[000.000.000.000] at Module._compile (module.js:456:26)
[000.000.000.000] at Object.Module._extensions..js (module.js:474:10)
[000.000.000.000] at Module.load (module.js:356:32)
[000.000.000.000] at Function.Module._load (module.js:312:12)
[000.000.000.000] at Module.require (module.js:364:17)
[000.000.000.000] at require (module.js:380:17)
[000.000.000.000] at Object.<anonymous> (/bundle/bundle/programs/server/boot.js:1:75)
[000.000.000.000] at Module._compile (module.js:456:26)
[000.000.000.000] at Object.Module._extensions..js (module.js:474:10)
[000.000.000.000] npm WARN deprecated This version of npm lacks support for important features,
[000.000.000.000] npm WARN deprecated such as scoped packages, offered by the primary npm
[000.000.000.000] npm WARN deprecated registry. Consider upgrading to at least npm@2, if not the
[000.000.000.000] npm WARN deprecated latest stable version. To upgrade to npm@2, run:
[000.000.000.000] npm WARN deprecated
[000.000.000.000] npm WARN deprecated npm -g install npm@latest-2
[000.000.000.000] npm WARN deprecated
[000.000.000.000] npm WARN deprecated To upgrade to the latest stable version, run:
[000.000.000.000] npm WARN deprecated
[000.000.000.000] npm WARN deprecated npm -g install npm@latest
[000.000.000.000] npm WARN deprecated
[000.000.000.000] npm WARN deprecated (Depending on how Node.js was installed on your system, you
[000.000.000.000] npm WARN deprecated may need to prefix the preceding commands with `sudo`, or if
[000.000.000.000] npm WARN deprecated on Windows, run them from an Administrator prompt.)
[000.000.000.000] npm WARN deprecated
[000.000.000.000] npm WARN deprecated If you're running the version of npm bundled with
[000.000.000.000] npm WARN deprecated Node.js 0.10 LTS, be aware that the next version of 0.10 LTS
[000.000.000.000] npm WARN deprecated will be bundled with a version of npm@2, which has some small
[000.000.000.000] npm WARN deprecated backwards-incompatible changes made to `npm run-script` and
[000.000.000.000] npm WARN deprecated semver behavior.
[000.000.000.000] npm WARN package.json meteor-dev-bundle@0.0.0 No description
[000.000.000.000] npm WARN package.json meteor-dev-bundle@0.0.0 No repository field.
[000.000.000.000] npm WARN package.json meteor-dev-bundle@0.0.0 No README data
[000.000.000.000] npm WARN cannot run in wd meteor-dev-bundle@0.0.0 node npm-rebuild.js (wd=/bundle/bundle/programs/server)
[000.000.000.000] => Starting meteor app on port:80
[000.000.000.000]
[000.000.000.000] /bundle/bundle/programs/server/node_modules/fibers/fibers.js:16
[000.000.000.000] throw new Error('`'+ modPath+ '.node` is missing. Try reinstalling `node-fibe
[000.000.000.000] ^
[000.000.000.000] Error: `/bundle/bundle/programs/server/node_modules/fibers/bin/linux-x64-v8-3.14/fibers.node` is missing. Try reinstalling `node-fibers`?
[000.000.000.000] at Object.<anonymous> (/bundle/bundle/programs/server/node_modules/fibers/fibers.js:16:8)
[000.000.000.000] at Module._compile (module.js:456:26)
[000.000.000.000] at Object.Module._extensions..js (module.js:474:10)
[000.000.000.000] at Module.load (module.js:356:32)
[000.000.000.000] at Function.Module._load (module.js:312:12)
[000.000.000.000] at Module.require (module.js:364:17)
[000.000.000.000] at require (module.js:380:17)
[000.000.000.000] at Object.<anonymous> (/bundle/bundle/programs/server/boot.js:1:75)
[000.000.000.000] at Module._compile (module.js:456:26)


The above error is also posted in this gist

(Small note: I removed my client's app name for privacy reasons and substituted "MyAppName" and "MyAppNameDir" and the Server IP has been masked as 000.000.000.000)

Is anyone aware of a new warning node is throwing? Perhaps this is the problem?

Anyone seen this before, or have a workaround to get things working again.

This crashed my production server. The website is entirely down!

Answer

Well... after posting this I just went back and ran

$ mupx deploy

again... And it just worked fine - deployed with no problems.

Another thing I found to avoid this in the future is to install NodeJS on my AWS instance. Following this link will do the trick. I'm not sure why they don't just add this to the mupx setup...

I also found some documentation which was helpful (and my next step to turn to if things were not working)

https://www.npmjs.com/package/mupx has some great documentation and there they say

"One of the most common problems is your Node version getting out of date. In that case, see “Updating” section above."

So, if you run into this problem - maybe the best thing to do is run

$ npm update mupx -g

as per: https://www.npmjs.com/package/mupx#updating-mup

However, for me it was as simple as running $ mupx deploy one more time after waiting a few minutes (kind of disturbing actually)