Nemanja Mandic Nemanja Mandic - 7 months ago 32
Ruby Question

Rails 4 , ImageMagick and PaperClip

When i want to upload image i get this error:

1 error prohibited this movie from being saved:
Image Could not run the `identify` command. Please install ImageMagick.


I have this in Gemgile:

gem 'imagemagick-identify', '~> 0.0.1'
gem 'paperclip', '~> 4.2.1'


i ran $ gem install imagemagick-identify

Answer

imagemagick-identify is just a wrapper for imagemagick's identify program. You will need to install imagemagick separately from the gem.

If you are using debian/ubuntu you can do sudo apt-get install imagemagick.

If you are on a Mac, you may find this helpful.

If you are on Windows, you can find binaries to install here.

Looks like there are binaries for other platforms available at the last link as well.

If you have installed imagemagick and still get that error, make sure it is in your PATH.