user1251007 user1251007 - 3 months ago 304
C++ Question

Project ERROR: Unknown module(s) in QT: webkitwidgets

I am porting code from qt4 to qt5. I added the following line to my

.pro
file, as suggested:

QT += webkitwidgets


However, when I run
qmake
, I get the this error:

Project ERROR: Unknown module(s) in QT: webkitwidgets


I am developing on Ubuntu 12.04 LTS and installed Qt as described.

Answer

You need to install the webkitwidgets library.

On Ubuntu, try this in a terminal:

sudo apt-get install libqt5webkit5-dev