Alexey Markov Alexey Markov - 1 month ago 8x
ASP.NET (C#) Question

Understanding versions of .NET Core and Entity Framework

I can't understand difference between lot of

framework names:
- dnxcore50
- dotnet5.4
- netcoreapp

is a new name for

I create Class Library project and there is
. Then I create empty ASP.NET project an dthere is

I add dependency to
Microsoft.EntityFrameworkCore 1.0.0
to project and get error:

The dependency Microsoft.EntityFrameworkCore does not support for framework NETPlatform, Version=v5.4

What is the correct framework version and Entity Framework version?


You can avoid so many issues if you use the latest tools and frameworks.

Here is the link : Visual Studio 2015 Update 3 and .NET Core 1.0

enter image description here

What are the Target Framework Monikers (TFMs) ?

The Target Framework Monikers are IDs of the type framework+version that you can target from your apps in .NET Core and ASP.NET Core.

As examples, you can use:

– “netcoreapp1.0” For .NET Core 1.0

– “net45”, “net451”, “net452”, “net46”, “net461” for .NET Framework versions

– “portable-net45+win8” for PCL profiles

– “dotnet5.6”, “dnxcore50” and others, for older .NET Core preview versions (Before .NET Core 1.0 RTM and .NET Core RC2 were released)

– “netstandard1.2”, “netstandard1.5”, etc. for .NET Standard Platform monikers.

The table below defines some examples of the latest frameworks (as of late June 2016) that you can use and how they are referred to and which version of the .NET Standard Library they implement :

enter image description here

You can read about it here : Running .NET Core apps on multiple frameworks and (TFMs)