Salman Salman - 1 year ago 101
Android Question

"Gradle Version 2.10 is required." Error

As I've been using

classpath ''

In the build.gradle file, I got the following error since gradle version 2.10 has been released.
The error is :

Warning:Gradle version 2.10 is required. Current version is 2.8. If
using the gradle wrapper, try editing the distributionUrl in

at first it looks easy to solve by the guide, but when I'd done the change, I got the error again.

I'm using Android Studio 2.0 with the latest Android SDK Tools 24.4.1 and Android SDK Build Tools 23.0.2

I've even tried to download Gradle 2.10 and put it manually on android-studio\gradle\ folder, but no luck.

Any help would be appreciated.

Answer Source

You need to change File > Settings > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home path

On Mac OS, change the path in Android Studio > Preferences > Builds,Execution,Deployment > Build Tools > Gradle >Gradle home

Or set Use default gradle wrapper and edit Project\gradle\wrapper\ files field distributionUrl like this

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download