Sree Sree - 5 months ago 43
Android Question

I am not able to compile Instance id for Google Play Services

I am trying to add the Instance Id (last line)

dependencies {
//Basic Google libs
compile 'com.android.support:support-v4:+'
compile 'com.android.support:appcompat-v7:22.2.0'
compile 'com.google.android.gms:play-services-base:7.5.0'
compile 'com.google.android.gms:play-services-gcm:7.5.0'
compile 'com.google.android.gms:play-services-location:7.5.0'
compile 'com.google.android.gms:play-services-maps:7.5.0'
compile 'com.google.android.gms:play-services-wallet:7.5.0'
compile 'com.google.android.gms.iid:7.5.0'
}


but I keep getting:

Error:Failed to resolve: com.google.android.gms.iid:7.5.0:

Any clue why?

Answer

There is nothing like : 'com.google.android.gms.iid:7.5.0' provided by google play services

If you are looking for identity service then it should be :

com.google.android.gms:play-services-identity:7.5.0

Refer link : https://developers.google.com/android/guides/setup

Comments