hrskrs hrskrs - 29 days ago 18
Android Question

Manifest error while implementing MaterialNavigationDrawer

I am trying to integrate this Material Drawer to my project, however i am facing a

Manifest
error. I have tried changing the
minSdk
and
targetSdk
as it is suggested on some similar questions but with no success.

Here is the error i get:

Error:Execution failed for task ':app:processDebugManifest'.
> Error: [project_path\build\intermediates\exploded-aar\it.neokree\MaterialNavigationDrawer\1.2.9\AndroidManifest.xml:8] Invalid instruction 'overrideLibrary', valid instructions are : REMOVE,REPLACE,STRICT


Here is my app manifest:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="my.package.name">

<application
android:allowBackup="true"
android:icon="@drawable/ic_launcher"
android:label="@string/app_name"
android:theme="@style/AppTheme">
<activity
android:name=".activities.SplashScreenActivity"
android:configChanges="orientation"
android:label="@string/app_name"
android:theme="@android:style/Theme.NoTitleBar.Fullscreen">
<intent-filter>
<action android:name="android.intent.action.MAIN" />

<category android:name="android.intent.category.LAUNCHER" />
</intent-filter>
</activity>
<activity
android:name=".MainActivity"
android:theme="@style/NavigationDrawer" />
</application>

</manifest>


I am using
Android Studio (Beta) 0.8.0
.
What is causing this error?

Answer

I solved the error by going to the MaterialDrawer library Manifest and removing the uses-sdk:

   <uses-sdk
        android:minSdkVersion="10"
        android:targetSdkVersion="21"
        tools:overrideLibrary="at.markushi.ui" >
    </uses-sdk>

I am not sure if that will bring up any error later on but at least it solve the problem i had