Alon Alon - 4 months ago 5
Node.js Question

can't install module 'merge-descriptors'

I'm new to node.js.
I'm using WebStorm. I work on Windows.

I configured my app to run on node.js and when I try to run it I get this error:"Cannot find module 'merge-descriptors'".

I followed these post trying to solve it: NodeJS - How to resolve "Cannot find module" error,
module.js:338 throw err in node.js

I ran "del /s /q node_modules" (parallel to "rm -rf node_modules").
Now I'm trying to run "npm install -g" and I'm getting this error:

See screen shot below
enter image description here

I've tried to understand it and to look for information about it in the net to no avail.

Any help will be profoundly appreciated!


When installing the dependencies for a package you should be using npm install and not using the -g flag.

The g flag, or global is used when installing a package globally, which places them in a direct location that is not accessible by the project.