Atif Atif - 5 months ago 402
Swift Question

Unable to install Firebase iOS SDK (v3.2.0)

I am unable to install Firebase iOS SDK (v3.2.0).
I followed instruction from Firebase but it will install legacy SDK v2.5.1

Podfile looks like

platform :ios, '9.0'

target 'FireBaseTestApp' do
use_frameworks!
pod 'Firebase', '>= 2.5.1'
pod 'Firebase/Core'

end


Error

[!] Unable to satisfy the following requirements:


  • Firebase/Core
    required by
    Podfile



None of your spec sources contain a spec satisfying the dependency:
Firebase/Core
.

You have either:
* out-of-date source repos which you can update with
pod repo update
.
* mistyped the name or version.
* not added the source repo that hosts the Podspec to your Podfile.

Answer

Change your podfile to

platform :ios, '9.0'
use_frameworks!

target 'FireBaseTestApp' do

pod 'Firebase'
pod 'Firebase/Database'

end
Comments