Julinho da Adelaide Julinho da Adelaide - 6 months ago 24
Ruby Question

Require command not working on GEM Ruby

I have installed Ruby, RailsInstaller and DevKit on C:/.

The command

gem install pipedrive-ruby


works fine as below.

image

When I test the instalation, it looks ok. Its shown on

gem list


but then when I try

require 'pipedrive-ruby'


Windows does not recognize.

I'm trying this gem https://github.com/GeneralScripting/pipedrive-ruby

Whats happening?

Answer

Actually I can not start any Ruby code from cmd, it's pretty basic but for a noobie I didn't know. The require command must be inside a .rb file or if from command line it must be "ruby -e "require 'pipedrive-ruby'"

Living and learning.