user1241320 user1241320 - 21 days ago 5
Scala Question

libjansi issue when trying to install Scala on Ubuntu 10.04

when i do

apt-get install scala



The following packages have unmet dependencies. scala: Depends:
libjansi-java but it is not installable E: Broken packages


Though when I do apt-cache show scala I get


Architecture: all Version: 2.7.7.dfsg-4ubuntu1 Depends: scala-library
(= 2.7.7.dfsg-4ubuntu1), openjdk-6-jre | java6-runtime Filename:
pool/universe/s/scala/scala_2.7.7.dfsg-4ubuntu1_all.deb

ron ron
Answer

That seems a very very old Scala included in the default repository.

Follow these instructions to install the Typesafe Stack with all the goodies. This is the official distribution of Scala and related tools.