syabro syabro - 1 month ago 21
Python Question

pip ignores dependency_links in

I have dependency_links in my

dependency_links = [''],

But it doesn't work. However install_requires works fine.
Maybe there are another method to set up git repo as required for


This answer should help. In a nutshell, you need to specify the version (or "dev") for the #egg=python-s3 so it looks like #egg=python-s3-1.0.0.

Updates based on @Cerin's comment:

  • Pip 1.5.x has a flag to enable dependency-links processing: --process-dependency-links. I haven't tested it because I agree with the point below.
  • This discussion seems to indicate that using dependency-links for pip is a bad practice (and may be deprecated).