Giovanni Côco Giovanni Côco - 4 months ago 102
iOS Question

Firebase pod install - pod 'Firebase/Database' - Required a higher minimum deployment target

I am trying to install Firebase/Database like Firebase doc but when I tried I got issue.

[!] Unable to satisfy the following requirements:

  • Firebase/Database
    required by

    Specs satisfying the
    dependency were found, but they required a higher minimum deployment target.

Required a higher minimum deployment target, how can I do this?




This is how I fixed it.

Step 1

Install Regular Firebase - pod 'Firebase', '>= 2.5.1'

Step 2

Update - pod update

*At this point it will take a good couple minutes to update. You should see something like this.

Update all pods
Updating local specs repositories
Analyzing dependencies
Downloading dependencies
Installing Firebase 3.2.0 (was 3.2.0)
Using FirebaseAnalytics (3.2.0)
Installing FirebaseAuth (3.0.2)
Using FirebaseDatabase (3.0.1)
Using FirebaseInstanceID (1.0.6)
Using GoogleInterchangeUtilities (1.2.1)
Installing GoogleNetworkingUtilities (1.2.1)
Using GoogleSymbolUtilities (1.1.1)
Using GoogleUtilities (1.3.1)
Generating Pods project
Integrating client project
Sending stats
Pod installation complete! There are 4 dependencies from the Podfile and 10
total pods installed.

Step 3

Now you should have Firebase 3. So you can add frameworks like such in your pod file then pod update

# Uncomment this line to define a global platform for your project
 platform :ios, '8.0'
# Uncomment this line if you're using Swift

target 'xMarket' do


target 'xMarketTests' do


target 'xMarketUITests' do


pod 'Firebase', '>= 2.5.1'
pod ‘Firebase/Core’
pod ‘Firebase/Database’
pod ‘Firebase/Auth’

Good luck!