Intrepidd Intrepidd - 6 months ago 19
Ruby Question

How to use the debugger with Ruby 2.0?

I know the debugger gem is not and never will be compatible with ruby 2.0 per "officially support ruby 2.X".

In the changelog of Ruby 2.0 is:


Debug support

DTrace support, which enables run-time diagnosis in

production TracePoint, which is an improved tracing API


Is there something out of the box for debugging with Ruby 2.0? Can somebody explain this to me?

Answer

The debugger gem can be used but it still has issues.

Install byebug which was written for Ruby 2.0 debugging.

For breakpoints, use the byebug command in your code instead of debugger.

Comments