Kanika Rawat Kanika Rawat - 1 month ago 86
Python Question

How to install scipy on windows 10?

I have windows 10 and i am trying to install scipy. Presently, I have tried pip, but it gave an error

Command "c:\python27\python.exe -u -c "import setuptools, tokenize;__file__='c:\\users\\kanika\\appdata\\local\\temp\\pip-build-4jzyxl\\scipy\\setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().repl


Then i downloaded scs-1.2.6-cp27-cp27m-win_amd64 from http://www.lfd.uci.edu/~gohlke/pythonlibs/
and tried to run this
pip install scs-1.2.6-cp27-cp27m-win_amd64

but still got error

Could not find a version that satisfies the requirement scs-1.2.6-cp27-cp27m-win_amd64 (from versions: )
No matching distribution found for scs-1.2.6-cp27-cp27m-win_amd64


How can i install scipy? I have numpy

Update 1-: I was able to install scipy but now i got error -:

No module named numpy+mkl


So i downloaded numpy-1.11.2+mkl-cp27-cp27m-win_amd64.whl from the same link. But i get this error-:

Invalid requirement: 'numpy-1.11.2+mkl-cp27-cp27m-win_amd64'
Traceback (most recent call last):
File "c:\python27\lib\site-packages\pip\req\req_install.py", line 78, in __init__
req = Requirement(req)
File "c:\python27\lib\site-packages\pip\_vendor\packaging\requirements.py", line 96, in __init__
requirement_string[e.loc:e.loc + 8]))
InvalidRequirement: Invalid requirement, parse error at "'+mkl-cp2'"


Why am i getting this error?

Answer

this is not scipy you are tring to install this is

(unstable), a C package for solving large-scale convex cone problems. Requires numpy+mkl..

on windows 64 bit to install scipy use Unofficial Windows Binaries for Python Extension Packages to avoid errors you can download .whl file from Scipy it's name scipy-0.18.1-cp27-cp27m-win_amd64.whl then go to download location of file using cmd the type :

pip install scipy-0.18.1-cp27-cp27m-win_amd64.whl

to solve the new error download Numpy+MKL from here file name is numpy-1.11.2+mkl-cp27-cp27m-win_amd64.whl

Comments