Mahdi.Pishguy Mahdi.Pishguy - 5 months ago 35
Node.js Question

Nodejs npm failed to install nodemon

i want to install

Nodemon
on my ubuntu, but i get an error and i could not

#npm install -g nodemon

npm WARN optional dep failed, continuing fsevents@1.0.12
/usr/bin/nodemon -> /usr/lib/node_modules/nodemon/bin/nodemon.js
nodemon@1.9.2 /usr/lib/node_modules/nodemon
├── ignore-by-default@1.0.1
├── undefsafe@0.0.3
├── es6-promise@3.2.1
├── debug@2.2.0 (ms@0.7.1)
├── minimatch@3.0.2 (brace-expansion@1.1.5)
├── touch@1.0.0 (nopt@1.0.10)
├── lodash.defaults@3.1.2 (lodash.restparam@3.6.1, lodash.assign@3.2.0)
├── ps-tree@1.1.0 (event-stream@3.3.3)
├── update-notifier@0.5.0 (is-npm@1.0.0, semver-diff@2.1.0, string-length@1.0.1, chalk@1.1.3, repeating@1.1.3, configstore@1.4.0, latest-version@1.0.1)
└── chokidar@1.6.0 (path-is-absolute@1.0.0, inherits@2.0.1, glob-parent@2.0.0, async-each@1.0.0, is-glob@2.0.1, is-binary-path@1.0.1, readdirp@2.1.0, anymatch@1.3.0)


and this is my ubuntu version:

root@ubuntu:/home/salam# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.4 LTS
Release: 14.04
Codename: trusty


i'm using root username and password for install it

Answer

It looks like it installed correctly.

The only error is a warning:

npm WARN optional dep failed, continuing fsevents@1.0.12

Please note that fsevents is only for OS X hosts (https://github.com/strongloop/fsevents) and is not needed on Linux/Ubuntu.

You should be able to run the nodemon command in your terminal to verify this.