Parth Anjaria Parth Anjaria - 1 month ago 15
Android Question

Error of 25.0.0 while compiling the project

I have a project which was running fine till date. Suddenly today facing these issue :

Error:A problem occurred configuring project ':app'.
> Could not resolve all dependencies for configuration ':app:_debugCompile'.
> Could not find com.android.support:appcompat-v7:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified
Yokura-Seeker:app:unspecified > com.android.support:design:23.4.0
> Could not find com.android.support:cardview-v7:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified
> Could not find com.android.support:support-v4:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified > com.android.support:design:23.4.0
Yokura-Seeker:app:unspecified > com.android.support:recyclerview-v7:23.4.0
> Could not find com.android.support:support-v4:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0
> Could not find com.android.support:appcompat-v7:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0
> Could not find com.android.support:cardview-v7:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0
> Could not find com.android.support:customtabs:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar
https://jcenter.bintray.com/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom
https://jcenter.bintray.com/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0
> Could not find com.android.support:support-v4:25.0.0.
Searched in the following locations:
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom
file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar
Required by:
Yokura-Seeker:app:unspecified > com.google.android.gms:play-services-auth:9.8.0 > com.google.android.gms:play-services-basement:9.8.0


I also dont have 25.0.0 in my sdk, havnt still downloaded it, and also my compile version is 23.0.2 then y is it searching for 25.0.0?

EDIT :

the Exact issue i am facing now is that i am using

compile 'com.facebook.android:facebook-android-sdk:4.+'


in gradle for facebook.

and in this library it is using 25.0.0 so how do i avoid that?

Answer

since you didn't specify exact version of facebook SDK: compile 'com.facebook.android:facebook-android-sdk:4.+', it uses any version (latest probably), which probably targets the latest SDK (25), and requires the latest support library versions.
So you have 2 ways to fix it:

  1. install missing libraries, and probably target SDK 25 in your project
  2. use some exact version of facebook SDK, which does not target latest Android SDK