bobsilon bobsilon - 6 months ago 108
Less Question

Bootstrap 4 supports LESS?

As nowadays bootstrap team announced the version 4 alpha which natively uses SASS as CSS preprocessor. Is this mean it hasn't any LESS support?!

Answer Source

You have to remember that Bootstrap 4 is in its Alpha phase. Currently it does not support LESS, as Bootstrap's blog entry on Bootstrap 4 Alpha states:

Moved from Less to Sass. Bootstrap now compiles faster than ever thanks to Libsass, and we join an increasingly large community of Sass developers.

However, version 4's Getting Started page does still give LESS a mention (although I imagine this is a copy/paste oversight):

npm

Bootstrap’s package.json contains some additional metadata under the following keys:

  • less - path to Bootstrap’s main Less source file

  • style - path to Bootstrap’s non-minified CSS that’s been precompiled using the default settings (no customization)

Whether it will support LESS in the future cannot be really determined without some form of official yay or nay, but currently it doesn't look like there are any plans involving it.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download