Aayush Aarwal Aayush Aarwal - 6 months ago 246
AngularJS Question

Error following angularjs2 Quickstart Guide error 404 'angular' is not in the npm registry

I recently cloned the official AngularJS Quickstart code and ran npm install. I received a 404. error 404 'angular' is not in the npm registry.
Here is my npm debug log:

17 silly registry.get 'content-length': '40',
517 silly registry.get 'accept-ranges': 'bytes',
517 silly registry.get date: 'Tue, 10 May 2016 15:00:17 GMT',
517 silly registry.get via: '1.1 varnish',
517 silly registry.get age: '0',
517 silly registry.get connection: 'keep-alive',
517 silly registry.get 'x-served-by': 'cache-sin6927-SIN',
517 silly registry.get 'x-cache': 'MISS',
517 silly registry.get 'x-cache-hits': '0',
517 silly registry.get 'x-timer': 'S1462892417.310196,VS0,VE210' } ]
518 silly lockFile b50e344d-angular-core-2-0-0-rc-1 angular/core@2.0.0-rc.1
519 silly lockFile b50e344d-angular-core-2-0-0-rc-1 angular/core@2.0.0-rc.1
520 error 404 'angular' is not in the npm registry.
520 error 404 You should bug the author to publish it
520 error 404
520 error 404 Note that you can also install from a
520 error 404 tarball, folder, or http url, or git url.
521 error System Linux 3.19.0-47-generic
522 error command "/usr/bin/nodejs" "/usr/bin/npm" "install"
523 error cwd /home/aayush/try2
524 error node -v v0.10.25
525 error npm -v 1.3.10
526 error code E404
527 verbose exit [ 1, true ]


Here is the package.json file:

{
"name": "angular2-quickstart",
"version": "1.0.0",
"description": "QuickStart package.json from the documentation, supplemented with testing support",
"scripts": {
"start": "tsc && concurrently \"tsc -w\" \"lite-server\" ",
"docker-build": "docker build -t ng2-quickstart .",
"docker": "npm run docker-build && docker run -it --rm -p 3000:3000 -p 3001:3001 ng2-quickstart",
"e2e": "tsc && concurrently \"http-server\" \"protractor protractor.config.js\"",
"lint": "tslint ./app/**/*.ts -t verbose",
"lite": "lite-server",
"postinstall": "typings install",
"test": "tsc && concurrently \"tsc -w\" \"karma start karma.conf.js\"",
"tsc": "tsc",
"tsc:w": "tsc -w",
"typings": "typings",
"webdriver:update": "webdriver-manager update"
},
"keywords": [],
"author": "",
"license": "ISC",
"dependencies": {
"@angular/common": "2.0.0-rc.1",
"@angular/compiler": "2.0.0-rc.1",
"@angular/core": "2.0.0-rc.1",
"@angular/http": "2.0.0-rc.1",
"@angular/platform-browser": "2.0.0-rc.1",
"@angular/platform-browser-dynamic": "2.0.0-rc.1",
"@angular/router": "2.0.0-rc.1",
"@angular/router-deprecated": "2.0.0-rc.1",
"@angular/upgrade": "2.0.0-rc.1",
"systemjs": "0.19.27",
"es6-shim": "^0.35.0",
"reflect-metadata": "^0.1.3",
"rxjs": "5.0.0-beta.6",
"zone.js": "^0.6.12",
"angular2-in-memory-web-api": "0.0.7",
"bootstrap": "^3.3.6",
"angular": "~1.5.5"
},
"devDependencies": {
"concurrently": "^2.0.0",
"lite-server": "^2.2.0",
"typescript": "^1.8.10",
"typings": "^0.8.1",
"canonical-path": "0.0.2",
"http-server": "^0.9.0",
"tslint": "^3.7.4",
"lodash": "^4.11.1",
"jasmine-core": "~2.4.1",
"karma": "^0.13.22",
"karma-chrome-launcher": "^0.2.3",
"karma-cli": "^0.1.2",
"karma-htmlfile-reporter": "^0.2.2",
"karma-jasmine": "^0.3.8",
"protractor": "^3.3.0",
"rimraf": "^2.5.2"
},
"repository": {}
}


Can someone tell what is wrong...which npm package to use and what code changes will i have to do in the offiial angular heroes tutorial. Thanks

Answer

It looks like it doesn't know what registry to point to since the package names look correct.

First try a cache clean.

npm cache clean

And if that doesn't work, specify the registry directly:

npm install <packagename> --registry http://registry.npmjs.org/