lock lock - 2 months ago 26
Ruby Question

Rails server 503 Service Unavailable Error

when I start my rails server using

ruby script/server
command, I am getting the following response

=> Booting WEBrick
=> Rails 2.3.9 application starting on http://0.0.0.0:3000
/home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/rails-2.3.9/lib/rails/gem_dependency.rb:21:in `add_frozen_gem_path': undefined method `source_index' for Gem:Module (NoMethodError)
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/rails-2.3.9/lib/initializer.rb:298:in `add_gem_load_paths'
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/rails-2.3.9/lib/initializer.rb:132:in `process'
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/rails-2.3.9/lib/initializer.rb:113:in `send'
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/rails-2.3.9/lib/initializer.rb:113:in `run'
from /home/ubuntu/apps/moogle/config/environment.rb:13
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/activesupport-2.3.9/lib/active_support/dependencies.rb:182:in `require'
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/activesupport-2.3.9/lib/active_support/dependencies.rb:182:in `require'
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/activesupport-2.3.9/lib/active_support/dependencies.rb:547:in `new_constants_in'
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/activesupport-2.3.9/lib/active_support/dependencies.rb:182:in `require'
from /home/ubuntu/.rvm/gems/ruby-1.8.7-p374@gemset1/gems/rails-2.3.9/lib/commands/server.rb:84
from script/server:3:in `require'
from script/server:3


I am using ProxyPreseve like

<VirtualHost *:80>
ProxyPreserveHost On
ProxyPass / http://0.0.0.0:3000/
ProxyPassReverse / http://0.0.0.0:3000/
ServerName localhost
</VirtualHost>


And I am getting 503 Service Unavailable Error. Can anyone tell me whats wrong in my application?

Rails version: 2.3.9
Ruby version: 1.8.7-p374
Bundle version: 1.12.5
Gem version: 2.0.17

Answer

You need to downgrade the rubygems version

gem update --system 1.8.25

refer solution to the same problem here

Comments