techdreams techdreams - 2 months ago 17
Ruby Question

already activated spring 1.4.0, but Gemfile requires spring 1.3.3[error]

My server is running fine but when I try to enter console by rails c I get this error.

/home/munam/.rvm/gems/ruby-2.2.0@jugojuice/gems/bundler-1.10.6/lib/bundler/runtime.rb:34:in `block in setup': You have already activated spring 1.4.0, but your Gemfile requires spring 1.3.3. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)
from /home/munam/.rvm/gems/ruby-2.2.0@jugojuice/gems/bundler-1.10.6/lib/bundler/runtime.rb:19:in `setup'
from /home/munam/.rvm/gems/ruby-2.2.0@jugojuice/gems/bundler-1.10.6/lib/bundler.rb:127:in `setup'
from /home/munam/.rvm/gems/ruby-2.2.0@jugojuice/gems/bundler-1.10.6/lib/bundler/setup.rb:8:in `<top (required)>'
from /home/munam/.rvm/rubies/ruby-2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /home/munam/.rvm/rubies/ruby-2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /home/munam/.rvm/gems/ruby-2.2.0@jugojuice/gems/spring-1.4.0/lib/spring/commands.rb:33:in `<module:Spring>'
from /home/munam/.rvm/gems/ruby-2.2.0@jugojuice/gems/spring-1.4.0/lib/spring/commands.rb:4:in `<top (required)>'
from /home/munam/.rvm/rubies/ruby-2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /home/munam/.rvm/rubies/ruby-2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
from /home/munam/.rvm/gems/ruby-2.2.0@jugojuice/gems/spring-1.4.0/lib/spring/server.rb:9:in `<top (required)>'
from /home/munam/.rvm/rubies/ruby-2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:128:in `require'
from /home/munam/.rvm/rubies/ruby-2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:128:in `rescue in require'
from /home/munam/.rvm/rubies/ruby-2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:39:in `require'


My Gemfile.lock is as below

GIT
remote: git://github.com/rails-api/active_model_serializers.git
revision: 1f08865a10bb06648efc170768c8c9937d441f45
specs:
active_model_serializers (0.10.0.rc3)
actionpack (>= 4.0)
activemodel (>= 4.0)
railties (>= 4.0)

GIT
remote: https://github.com/enriclluelles/route_translator.git
revision: f00b4688542689fcb99f3792d2e691e9a3c474f1
specs:
route_translator (4.0.0)
actionpack (>= 3.0, < 5.0)
activesupport (>= 3.0, < 5.0)

GEM
remote: https://rubygems.org/
specs:
actionmailer (4.2.0)
actionpack (= 4.2.0)
actionview (= 4.2.0)
activejob (= 4.2.0)
mail (~> 2.5, >= 2.5.4)
rails-dom-testing (~> 1.0, >= 1.0.5)
actionpack (4.2.0)
actionview (= 4.2.0)
activesupport (= 4.2.0)
rack (~> 1.6.0)
rack-test (~> 0.6.2)
rails-dom-testing (~> 1.0, >= 1.0.5)
rails-html-sanitizer (~> 1.0, >= 1.0.1)
actionview (4.2.0)
activesupport (= 4.2.0)
builder (~> 3.1)
erubis (~> 2.7.0)
rails-dom-testing (~> 1.0, >= 1.0.5)
rails-html-sanitizer (~> 1.0, >= 1.0.1)
activejob (4.2.0)
activesupport (= 4.2.0)
globalid (>= 0.3.0)
activemodel (4.2.0)
activesupport (= 4.2.0)
builder (~> 3.1)
activerecord (4.2.0)
activemodel (= 4.2.0)
activesupport (= 4.2.0)
arel (~> 6.0)
activesupport (4.2.0)
i18n (~> 0.7)
json (~> 1.7, >= 1.7.7)
minitest (~> 5.1)
thread_safe (~> 0.3, >= 0.3.4)
tzinfo (~> 1.1)
acts_as_list (0.7.2)
activerecord (>= 3.0)
addressable (2.3.7)
arel (6.0.0)
autoprefixer-rails (5.1.7.1)
execjs
json
awesome_nested_set (3.0.2)
activerecord (>= 4.0.0, < 5)
aws-sdk (1.6.3)
httparty (~> 0.7)
json (~> 1.4)
nokogiri (>= 1.4.4)
uuidtools (~> 2.1)
bcrypt (3.1.10)
better_errors (2.1.1)
coderay (>= 1.0.0)
erubis (>= 2.6.6)
rack (>= 0.9.0)
binding_of_caller (0.7.2)
debug_inspector (>= 0.0.1)
blazing (0.4.1)
activesupport
grit
i18n
logging
thor
blazing-foreman (0.1.1)
activesupport
blazing (>= 0.2.9)
foreman
blazing-rails (0.1.4)
blazing (>= 0.2.9)
httparty
blazing-upstart (0.1.0)
activesupport
blazing (>= 0.2.9)
bootstrap-kaminari-views (0.0.5)
kaminari (>= 0.13)
rails (>= 3.1)
bootstrap-sass (3.3.4.1)
autoprefixer-rails (>= 5.0.0.1)
sass (>= 3.2.19)
bootstrap3-datetimepicker-rails (4.7.14)
momentjs-rails (>= 2.8.1)
bootswatch-rails (3.2.4)
railties (>= 3.1)
breakpoint (2.5.0)
sass (~> 3.3)
sassy-maps (< 1.0.0)
buftok (0.2.0)
builder (3.2.2)
cancancan (1.10.1)
capybara (2.4.4)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
xpath (~> 2.0)
celluloid (0.16.0)
timers (~> 4.0.0)
childprocess (0.5.5)
ffi (~> 1.0, >= 1.0.11)
chunky_png (1.3.4)
ckeditor (4.1.1)
cocaine
orm_adapter (~> 0.5.0)
climate_control (0.0.3)
activesupport (>= 3.0)
cocaine (0.5.7)
climate_control (>= 0.0.3, < 1.0)
coderay (1.1.0)
coffee-rails (4.1.0)
coffee-script (>= 2.2.0)
railties (>= 4.0.0, < 5.0)
coffee-script (2.3.0)
coffee-script-source
execjs
coffee-script-source (1.9.1)
compass (1.0.3)
chunky_png (~> 1.2)
compass-core (~> 1.0.2)
compass-import-once (~> 1.0.5)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
sass (>= 3.3.13, < 3.5)
compass-core (1.0.3)
multi_json (~> 1.0)
sass (>= 3.3.0, < 3.5)
compass-import-once (1.0.5)
sass (>= 3.2, < 3.5)
compass-rails (2.0.4)
compass (~> 1.0.0)
sass-rails (<= 5.0.1)
sprockets (< 2.13)
crass (1.0.1)
dalli (2.7.2)
database_cleaner (1.4.1)
debug_inspector (0.0.2)
devise (3.4.1)
bcrypt (~> 3.0)
orm_adapter (~> 0.1)
railties (>= 3.2.6, < 5)
responders
thread_safe (~> 0.1)
warden (~> 1.2.3)
diff-lcs (1.2.5)
docile (1.1.5)
dotenv (2.0.0)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
equalizer (0.0.9)
erubis (2.7.0)
eventmachine (1.0.7)
execjs (2.4.0)
factory_girl (4.5.0)
activesupport (>= 3.0.0)
factory_girl_rails (4.5.0)
factory_girl (~> 4.5.0)
railties (>= 3.0.0)
faraday (0.9.1)
multipart-post (>= 1.2, < 3)
faraday_middleware (0.9.2)
faraday (>= 0.7.4, < 0.10)
ffi (1.9.6)
font-awesome-rails (4.3.0.0)
railties (>= 3.2, < 5.0)
foreman (0.63.0)
dotenv (>= 0.7)
thor (>= 0.13.6)
formatador (0.2.5)
friendly_id (5.1.0)
activerecord (>= 4.0.0)
friendly_id-globalize (1.0.0.alpha1)
friendly_id (>= 5.0.0.beta4, < 6.0)
geocoder (1.2.8)
get_process_mem (0.2.0)
git-deploy (0.5.4)
net-scp
net-ssh
thor
globalid (0.3.3)
activesupport (>= 4.1.0)
globalize (5.0.1)
activemodel (>= 4.2.0, < 4.3)
activerecord (>= 4.2.0, < 4.3)
globalize-accessors (0.2.0)
globalize (~> 5.0.0)
globalize-versioning (0.1.0)
activemodel (>= 3.2.0, < 5)
activerecord (>= 3.2.0, < 5)
globalize (>= 3.0.4, < 6)
paper_trail (~> 3.0.0)
gmaps4rails (2.1.2)
grit (2.5.0)
diff-lcs (~> 1.1)
mime-types (~> 1.15)
posix-spawn (~> 0.3.6)
guard (2.12.4)
formatador (>= 0.2.4)
listen (~> 2.7)
lumberjack (~> 1.0)
nenv (~> 0.1)
notiffany (~> 0.0)
pry (>= 0.9.12)
shellany (~> 0.0)
thor (>= 0.18.1)
guard-compat (1.2.1)
guard-livereload (2.4.0)
em-websocket (~> 0.5)
guard (~> 2.8)
multi_json (~> 1.8)
guard-rspec (4.5.0)
guard (~> 2.1)
guard-compat (~> 1.1)
rspec (>= 2.99.0, < 4.0)
haml (4.0.6)
tilt
haml-rails (0.9.0)
actionpack (>= 4.0.1)
activesupport (>= 4.0.1)
haml (>= 4.0.6, < 5.0)
html2haml (>= 1.0.1)
railties (>= 4.0.1)
has_draft (1.3.0)
activerecord (>= 3.0.0)
activesupport (>= 3.0.0)
hashie (3.4.3)
hike (1.2.3)
hitimes (1.2.2)
html2haml (2.0.0)
erubis (~> 2.7.0)
haml (~> 4.0.0)
nokogiri (~> 1.6.0)
ruby_parser (~> 3.5)
http (0.6.3)
http_parser.rb (~> 0.6.0)
http_parser.rb (0.6.0)
http_signatures (0.2.2)
httparty (0.13.3)
json (~> 1.8)
multi_xml (>= 0.5.2)
i18n (0.7.0)
instagram (1.1.6)
faraday (>= 0.7, < 0.10)
faraday_middleware (>= 0.8, < 0.10)
hashie (>= 0.4.0)
multi_json (~> 1.0, >= 1.0.3)
jbuilder (2.2.11)
activesupport (>= 3.0.0, < 5)
multi_json (~> 1.2)
jquery-rails (4.0.3)
rails-dom-testing (~> 1.0)
railties (>= 4.2.0)
thor (>= 0.14, < 2.0)
jquery-ui-rails (5.0.3)
railties (>= 3.2.16)
jquery-validation-rails (1.13.1)
railties (>= 3.2, < 5.0)
thor (~> 0.14)
json (1.8.2)
jwt (1.5.2)
kaminari (0.16.3)
actionpack (>= 3.0.0)
activesupport (>= 3.0.0)
kgio (2.9.3)
launchy (2.4.3)
addressable (~> 2.3)
libv8 (3.16.14.7)
listen (2.9.0)
celluloid (>= 0.15.2)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
little-plugger (1.1.3)
logging (1.8.2)
little-plugger (>= 1.1.3)
multi_json (>= 1.8.4)
loofah (2.0.1)
nokogiri (>= 1.5.9)
lumberjack (1.0.9)
mail (2.6.3)
mime-types (>= 1.16, < 3)
memoizable (0.4.2)
thread_safe (~> 0.3, >= 0.3.1)
method_source (0.8.2)
mime-types (1.25.1)
mini_portile (0.6.2)
minitest (5.5.1)
momentjs-rails (2.10.2)
railties (>= 3.1)
multi_json (1.11.0)
multi_xml (0.5.5)
multipart-post (2.0.0)
naught (1.0.0)
nenv (0.2.0)
net-scp (1.2.1)
net-ssh (>= 2.6.5)
net-ssh (2.9.2)
nokogiri (1.6.6.2)
mini_portile (~> 0.6.0)
nokogumbo (1.2.0)
nokogiri
notiffany (0.0.6)
nenv (~> 0.1)
shellany (~> 0.0)
oauth2 (1.0.0)
faraday (>= 0.8, < 0.10)
jwt (~> 1.0)
multi_json (~> 1.3)
multi_xml (~> 0.5)
rack (~> 1.2)
omniauth (1.2.2)
hashie (>= 1.2, < 4)
rack (~> 1.0)
omniauth-facebook (3.0.0)
omniauth-oauth2 (~> 1.2)
omniauth-oauth2 (1.4.0)
oauth2 (~> 1.0)
omniauth (~> 1.2)
orm_adapter (0.5.0)
paper_trail (3.0.7)
activerecord (>= 3.0, < 5.0)
activesupport (>= 3.0, < 5.0)
paperclip (4.2.1)
activemodel (>= 3.0.0)
activesupport (>= 3.0.0)
cocaine (~> 0.5.3)
mime-types
pg (0.18.1)
posix-spawn (0.3.10)
pr_geohash (1.0.0)
pry (0.10.1)
coderay (~> 1.1.0)
method_source (~> 0.8.1)
slop (~> 3.4)
pry-rails (0.3.4)
pry (>= 0.9.10)
quiet_assets (1.1.0)
railties (>= 3.1, < 5.0)
rack (1.6.0)
rack-livereload (0.3.15)
rack
rack-rewrite (1.5.1)
rack-test (0.6.3)
rack (>= 1.0)
rails (4.2.0)
actionmailer (= 4.2.0)
actionpack (= 4.2.0)
actionview (= 4.2.0)
activejob (= 4.2.0)
activemodel (= 4.2.0)
activerecord (= 4.2.0)
activesupport (= 4.2.0)
bundler (>= 1.3.0, < 2.0)
railties (= 4.2.0)
sprockets-rails
rails-deprecated_sanitizer (1.0.3)
activesupport (>= 4.2.0.alpha)
rails-dom-testing (1.0.5)
activesupport (>= 4.2.0.beta, < 5.0)
nokogiri (~> 1.6.0)
rails-deprecated_sanitizer (>= 1.0.1)
rails-html-sanitizer (1.0.2)
loofah (~> 2.0)
rails_12factor (0.0.3)
rails_serve_static_assets
rails_stdout_logging
rails_serve_static_assets (0.0.4)
rails_stdout_logging (0.0.3)
railties (4.2.0)
actionpack (= 4.2.0)
activesupport (= 4.2.0)
rake (>= 0.8.7)
thor (>= 0.18.1, < 2.0)
raindrops (0.13.0)
rake (10.4.2)
rb-fsevent (0.9.4)
rb-inotify (0.9.5)
ffi (>= 0.5.0)
rdoc (4.2.0)
json (~> 1.4)
ref (1.0.5)
responders (2.1.0)
railties (>= 4.2.0, < 5)
rsolr (1.0.12)
builder (>= 2.1.2)
rspec (3.2.0)
rspec-core (~> 3.2.0)
rspec-expectations (~> 3.2.0)
rspec-mocks (~> 3.2.0)
rspec-core (3.2.2)
rspec-support (~> 3.2.0)
rspec-expectations (3.2.0)
diff-lcs (>= 1.2.0, < 2.0)
rspec-support (~> 3.2.0)
rspec-mocks (3.2.1)
diff-lcs (>= 1.2.0, < 2.0)
rspec-support (~> 3.2.0)
rspec-rails (3.2.1)
actionpack (>= 3.0, < 4.3)
activesupport (>= 3.0, < 4.3)
railties (>= 3.0, < 4.3)
rspec-core (~> 3.2.0)
rspec-expectations (~> 3.2.0)
rspec-mocks (~> 3.2.0)
rspec-support (~> 3.2.0)
rspec-support (3.2.2)
ruby_parser (3.6.5)
sexp_processor (~> 4.1)
rubyzip (1.1.7)
sanitize (3.1.2)
crass (~> 1.0.1)
nokogiri (>= 1.4.4)
nokogumbo (= 1.2.0)
sass (3.4.13)
sass-rails (5.0.1)
railties (>= 4.0.0, < 5.0)
sass (~> 3.1)
sprockets (>= 2.8, < 4.0)
sprockets-rails (>= 2.0, < 4.0)
tilt (~> 1.1)
sassy-maps (0.4.0)
sass (~> 3.3)
sdoc (0.4.1)
json (~> 1.7, >= 1.7.7)
rdoc (~> 4.0)
selenium-webdriver (2.45.0)
childprocess (~> 0.5)
multi_json (~> 1.0)
rubyzip (~> 1.0)
websocket (~> 1.0)
sexp_processor (4.5.0)
shellany (0.0.1)
shoulda-matchers (2.8.0)
activesupport (>= 3.0.0)
simple_form (3.1.0)
actionpack (~> 4.0)
activemodel (~> 4.0)
simple_oauth (0.3.1)
simplecov (0.9.2)
docile (~> 1.1.0)
multi_json (~> 1.0)
simplecov-html (~> 0.9.0)
simplecov-html (0.9.0)
slop (3.6.0)
spring (1.3.3)
sprockets (2.12.3)
hike (~> 1.2)
multi_json (~> 1.0)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sprockets-rails (2.2.4)
actionpack (>= 3.0)
activesupport (>= 3.0)
sprockets (>= 2.8, < 4.0)
stream-ruby (2.2.3)
http_signatures (~> 0)
httparty (~> 0)
stream_rails (2.3.1)
actionpack (>= 3.0.0)
activerecord (>= 3.0.0)
railties (>= 3.0.0)
stream-ruby (~> 2.2.3)
sunspot (2.2.0)
pr_geohash (~> 1.0)
rsolr (~> 1.0.7)
sunspot_rails (2.2.0)
nokogiri
rails (>= 3)
sunspot (= 2.2.0)
sunspot_solr (2.2.0)
susy (2.2.2)
sass (>= 3.3.0, < 3.5)
therubyracer (0.12.1)
libv8 (~> 3.16.14.0)
ref
thor (0.19.1)
thread_safe (0.3.5)
tilt (1.4.1)
timecop (0.7.3)
timers (4.0.1)
hitimes
truncate_html (0.9.3)
turbolinks (2.5.3)
coffee-rails
twitter (5.14.0)
addressable (~> 2.3)
buftok (~> 0.2.0)
equalizer (~> 0.0.9)
faraday (~> 0.9.0)
http (~> 0.6.0)
http_parser.rb (~> 0.6.0)
json (~> 1.8)
memoizable (~> 0.4.0)
naught (~> 1.0)
simple_oauth (~> 0.3.0)
twitter-text (1.11.0)
unf (~> 0.1.0)
tzinfo (1.2.2)
thread_safe (~> 0.1)
uglifier (2.7.1)
execjs (>= 0.3.0)
json (>= 1.8.0)
unf (0.1.4)
unf_ext
unf_ext (0.0.6)
unicorn (4.8.3)
kgio (~> 2.6)
rack
raindrops (~> 0.7)
unicorn-worker-killer (0.4.3)
get_process_mem (~> 0)
unicorn (~> 4)
uuidtools (2.1.5)
validates_email_format_of (1.6.2)
i18n
warden (1.2.3)
rack (>= 1.0)
websocket (1.2.1)
xpath (2.0.0)
nokogiri (~> 1.3)
xray-rails (0.1.16)
coffee-rails
rails (>= 3.1.0)

PLATFORMS
ruby

DEPENDENCIES
active_model_serializers!
acts_as_list
awesome_nested_set
aws-sdk (= 1.6.3)
better_errors
binding_of_caller
blazing
blazing-foreman
blazing-rails
blazing-upstart
bootstrap-kaminari-views
bootstrap-sass (~> 3.3.4)
bootstrap3-datetimepicker-rails (~> 4.7.14)
bootswatch-rails
breakpoint
cancancan
capybara
ckeditor
coffee-rails (~> 4.1.0)
compass
compass-rails
dalli
database_cleaner
devise
execjs
factory_girl_rails
font-awesome-rails
foreman (~> 0.63.0)
friendly_id
friendly_id-globalize
geocoder
git-deploy
globalize (~> 5.0.0)
globalize-accessors
globalize-versioning
gmaps4rails
guard
guard-livereload
guard-rspec
haml-rails
has_draft
instagram
jbuilder (~> 2.0)
jquery-rails
jquery-ui-rails
jquery-validation-rails
kaminari
launchy
momentjs-rails (>= 2.9.0)
omniauth-facebook
paper_trail (~> 3.0.5)
paperclip
pg
pry-rails
quiet_assets
rack-livereload
rack-rewrite
rails (= 4.2.0)
rails_12factor
rails_serve_static_assets
rails_stdout_logging
rb-fsevent
route_translator!
rspec
rspec-rails
sanitize
sass-rails (~> 5.0)
sdoc (~> 0.4.0)
selenium-webdriver
shoulda-matchers
simple_form
simplecov
spring
stream_rails
sunspot_rails
sunspot_solr
susy
therubyracer
timecop
truncate_html
turbolinks
twitter
twitter-text
uglifier (>= 1.3.0)
unicorn
unicorn-worker-killer
validates_email_format_of
xray-rails

BUNDLED WITH
1.10.6


As seen in it it has spring 1.3.3 only. What do I need to change so that the issue is fixed. I am ruby 2.2.0 and rails 4.2.0 Thanks in advance.

Answer

I fixed it using this.

bundle update spring