oscar oscar - 3 months ago 12
Ruby Question

Error with `rbenv install 2.2.0`

Trying to Setup Ruby On Rails on
Ubuntu 14.04 Trusty Tahr


The console error ouput:

rbenv install 2.2.0
Downloading ruby-2.2.0.tar.gz...
-> http://dqw8nmjcqpjn7.cloudfront.net/7671e394abfb5d262fbcd3b27a71bf78737c7e9347fa21c39e58b0bb9c4840fc
Installing ruby-2.2.0...

BUILD FAILED (Ubuntu 14.04 using ruby-build 20150112)

Inspect or clean up the working tree at /tmp/ruby-build.20150113142305.19357
Results logged to /tmp/ruby-build.20150113142305.19357.log

Last 10 log lines:
compiling ossl_digest.c
compiling ossl_x509name.c
compiling ossl_bio.c
compiling ossl_config.c
compiling ossl_asn1.c
installing default openssl libraries
linking shared-object openssl.so
make[2]: Leaving directory `/tmp/ruby-build.20150113142305.19357/ruby-2.2.0/ext/openssl'
make[1]: Leaving directory `/tmp/ruby-build.20150113142305.19357/ruby-2.2.0'
make: *** [build-ext] Error 2


Log file ruby-build.20150113142305.19357.log.

Answer

Ruby 2.2.0 requires the devel version of libffi, so this should help:

sudo apt-get install libffi-dev

Comments