Sahil Kapoor Sahil Kapoor - 1 month ago 40
iOS Question

This iMessage application is missing its required iMessage app extension

Using Xcode 8.0, running stickers app on iPhone (with iOS 10.0.2) gives me this error:

This iMessage application is missing its required iMessage app extension


It runs fine on simulator. What am I doing wrong? I'm using Xcode 8.1 Beta .

vj9 vj9
Answer

Please check if your deployment target is less than your device iOS version. If you are running Xcode Beta with deployment target 10.1, your device must be at least on same beta version. Reduce your deployment target to 10.0 otherwise.