Speedychuck Speedychuck - 7 months ago 18
Ruby Question

rest_client gem is deprecated and will be removed from RubyGems. Please use rest-client gem instead

Trying to get started with API testing using rest client in ruby, however, hitting issue after issue, any how hopefully someone will be able to help.

I am using RVM ruby-2.0.0-p648

I have rest_client External Lib files, however, when I try to run my script I get the message: WARNING: The rest_client gem is deprecated and will be removed from RubyGems. Please use rest-client gem instead.

Process finished with exit code 0

So in my require I changed to rest-client and installed: gem install rest-client, however it is not showing in my external Libraries?

Anyone hit this issue before with a solution?

Also using rubymine.

Answer

Looks like you figured this out, but just to be clear...

You want to update the Gemfile.

Change

gem 'rest_client'

to

gem 'rest-client'

and then run bundle install.

Comments