Joel Klabo Joel Klabo - 2 months ago 125
Swift Question

Can't Upload .ipa from Xcode 8, "The info.plist indicates a iOS app, but submitting a pkg or mpkg."

I am trying to submit my app. It is written in swift 3 and has an iOS 10 deployment target. So, I need to use Xcode 8. When I create an archive everything goes fine. I have even looked into the .ipa and everything seems fine.

But, every time I get this error:
The info.plist indicates a iOS app, but submitting a pkg or mpkg.

No idea what's going on. I'm not using any frameworks. No cocoapods. Very simple app.

Edit: Still no information on this. I have made a support request with Apple so we will see if that provides any new info. I can't be the only person experiencing this bug.

Answer

I was encountering this issue when updating a very old app. I was able to fix it by changing my Info.plist.

I had to change the LSMinimumSystemVersion key ("Minimum system version") to MinimumOSVersion ("MinimumOSVersion").

Before

Before

After

enter image description here