cnst cnst - 10 days ago 8
Ruby Question

Ruby: install a yanked gem (e.g. wkpdf on OS X 10.9)

I'd like to install wkpdf as per http://apple.stackexchange.com/questions/122176/convert-html-to-pdf-with-page-margins-and-hyperlinks, but, as per http://plessl.github.io/wkpdf/ and https://rubygems.org/gems/wkpdf, the gem "wkpdf" is "yanked", even though it should most likely still be in the working order.

% sudo gem install wkpdf
ERROR: Could not find a valid gem 'wkpdf' (>= 0) in any repository
11.556u 0.437s 0:29.63 40.4% 0+0k 57+1io 363pf+0w


Is there a way to install it nonetheless? I'm running OS X 10.9,
gem -v
returns
2.0
,

Answer

The project is still online here:

https://github.com/plessl/wkpdf

You can do the following:

$ wget https://github.com/plessl/wkpdf/archive/v0.6.11.tar.gz
$ tar -xf v0.6.11.tar.gz
$ cd wkpdf-0.6.11
$ gem build wkpdf.gemspec
$ sudo gem install wkpdf-0.6.11-universal-darwin.gem