maddy2u maddy2u - 1 month ago 40
R Question

Error while using install_github | devtools | timeout issue

I'm facing this issue when i try to download and install a package from git-hub using devtools.

R Version : 3.1.3 (64 bit)

> install_github("hadley/httr")
Downloading github repo hadley/httr@master
Error in curl::curl_fetch_memory(url, handle = handle) :
Timeout was reached

> traceback()
13: .Call(R_curl_fetch_memory, url, handle)
12: curl::curl_fetch_memory(url, handle = handle)
11: request_fetch.write_memory(req$output, req$url, handle)
10: request_fetch(req$output, req$url, handle)
9: request_perform(req, hu$handle$handle)
8: httr::HEAD(src_submodules, , auth)
7: github_has_remotes(x, auth)
6: remote_download.github_remote(remote, quiet = quiet)
5: remote_download(remote, quiet = quiet)
4: FUN(X[[1L]], ...)
3: vapply(remotes, install_remote, ..., FUN.VALUE = logical(1))
2: install_remotes(remotes, ...)
1: install_github("hadley/httr")


Edits:

I am using Revolution R Enterprise 7.4 with a Rstudio client.

Answer

The issue is resolved. The issue was resolved post me entering this option prior to install_github command.

> options(download.file.method = "wininet")
> library("devtools")
> install_github("ropensci/plotly")
Downloading github repo ropensci/plotly@master
Installing plotly
Skipping 4 packages not available: ggplot2, knitr, RCurl, RJSONIO
"C:/PROGRA~1/R/R-31~1.3/bin/x64/R" --no-site-file --no-environ --no-save --no-restore CMD INSTALL  \
  "C:/Users/310189051/AppData/Local/Temp/RtmpQNg1ji/devtools3e1c750f67e4/ropensci-plotly-6ff8831" --library="C:/Program  \
  Files/R/R-3.1.3/library" --install-tests 

* installing *source* package 'plotly' ...
** R
** inst
** tests
** preparing package for lazy loading
** help
*** installing help indices
** building package indices
** testing if installed package can be loaded
*** arch - i386
Error : .onLoad failed in loadNamespace() for 'RevoScaleR', details:
  call: inDL(x, as.logical(local), as.logical(now), ...)
  error: unable to load shared object 'C:/Program Files/R/R-3.1.3/library/RevoScaleR/rxLibs/x64/RxLink.dll':
  LoadLibrary failure:  %1 is not a valid Win32 application.
*** arch - x64
* DONE (plotly)
> library(plotly)
Loading required package: RCurl
Loading required package: bitops
Loading required package: RJSONIO
Loading required package: ggplot2
Comments