fakedrake fakedrake - 7 months ago 29
Python Question

Travis special requirements for each python version

I need unittest2 and importlib for python 2.6 that is not required for other python versions that travis tests against.

Is there a way to tell Travis-CI to have different requirements.txt files for each python version?

Answer

Travis CI adds an environment variable called $TRAVIS_PYTHON_VERSION that can be referenced in your .travis.yml:

python:
  - 2.6
  - 2.7
  - 3.2
  - 3.3
  - pypy
install:
  - if [[ $TRAVIS_PYTHON_VERSION == 2.6 ]]; then pip install importlib unittest2; fi
  - pip install -r requirements.txt

This would cause unittest2 and importlib to be installed only for Python 2.6, with requirements.txt being installed for all versions listed. You can do as many of these checks as necessary. Tornado's .travis.yml file uses it quite a bit.

Comments