Carl Tidén Carl Tidén - 4 months ago 81
Linux Question

Get pip3 to work on linux

I've successfully installed Python 3.5.2 on my CentOS 6.5 system. I'm, trying to get pip to work with this version of Python to be able to install some modules.

When I run

$ pip3 install ...
, it says command not found.

I've also tried to run:

$ sudo yum install python3-pip


... But that just returns: No package python3-pip available.

EDIT

Also done:

$ python3 get-pip.py


But it says:


zipimport.ZipImportError: can't decompress data; zlib not available


How am I supposed to get this working?

Answer

zipimport.ZipImportError: can't decompress data; zlib not available

Then get ZLIB

yum install zlib-devel 

pip 8.1.1 requires SSL/TLS

Then get SSL...

yum install openssl-devel
python3 -m ensurepip

In any case, since the pip version is being printed, you already have pip installed, you just need to determine why it won't run

Comments