MattR MattR - 10 days ago 6
Python Question

Cannot Import easygui module

This is my first question on Stack Oveflow, so forgive me if I do something wrong.
I've been using Python for a few months. I'm trying to make a simple GUI. I came across EasyGUI.

When i try to import the module, i get an error:

Traceback (most recent call last):
File "C:/Users/matthewr/PycharmProjects/testing start/Tsting.py", line 1, in <module>
import easygui
File "C:\Users\matthewr\AppData\Local\Programs\Python\Python35-32\lib\site-packages\easygui\__init__.py", line 50, in <module>
from .boxes.choice_box import choicebox
File "C:\Users\matthewr\AppData\Local\Programs\Python\Python35-32\lib\site-packages\easygui\boxes\choice_box.py", line 76
except Exception, e:
^
SyntaxError: invalid syntax


I erased everything in my code except
import easygui
but the error still comes up.

I uninstalled and reinstalled using pip, but no luck.

any help would be appreciated.

Answer

Try easygui 0.96.0

I've been using easygui for some time but I had exactly the same problem today on a new machine with a fresh install of 3.5.2 with easygui 0.98.0. However, easygui 0.96.0 works for me.

  1. reverted to Py 3.5.1, same problem.
  2. easygui 0.97 same issue on both Py 3.5.1, and 3.5.2
  3. Py 3.5.2 with easygui 0.96.0 - works fine!

pip uninstall easygui

pip install easygui==0.96.0

Comments