felix fritz felix fritz - 23 days ago 5
Java Question

Installing EGit on eclipse causes problems

I've tried installing the EGit plugin on Eclipse with this link: http://download.eclipse.org/egit/updates

I chose both, the

Eclipse Git Team Provider
and
JGit
and hit on next. Then, the window says
The operation cannot be completed. See the details.
.

This is the window:

enter image description here

The error lines say:


Cannot complete the install because of a conflicting dependency.

Software being installed: Eclipse Git Team Provider 3.0.3.201309161630-r
(org.eclipse.egit.feature.group 3.0.3.201309161630-r)

Software currently installed: Eclipse SDK 3.7.2.M20120208-0800 (org.eclipse.sdk.ide 3.7.2.M20120208-0800)

Only one of the following can be installed at once:
Team Support Core 3.7.0.v20130514-1224 (org.eclipse.team.core 3.7.0.v20130514-1224)
Team Support Core 3.5.0.I20090527-0620 (org.eclipse.team.core 3.5.0.I20090527-0620)
Team Support Core 3.5.1.r35x_20100113-0800 (org.eclipse.team.core 3.5.1.r35x_20100113-0800)
Team Support Core 3.6.0.I20110525-0800 (org.eclipse.team.core 3.6.0.I20110525-0800)


Cannot satisfy dependency:
From: Eclipse Git Team Provider 3.0.3.201309161630-r (org.eclipse.egit.feature.group 3.0.3.201309161630-r)
To: org.eclipse.egit.ui [3.0.3.201309161630-r]


Cannot satisfy dependency:
From: Git Team Provider UI 3.0.3.201309161630-r (org.eclipse.egit.ui 3.0.3.201309161630-r)
To: bundle org.eclipse.team.core [3.6.100,4.0.0)


Cannot satisfy dependency:
From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
To: org.eclipse.team.core [3.6.0.I20110525-0800]


Cannot satisfy dependency:
From: Eclipse Project SDK 3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8 (org.eclipse.sdk.feature.group 3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8)
To: org.eclipse.platform.feature.group [3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q]


Cannot satisfy dependency:
From: Eclipse SDK 3.7.2.M20120208-0800 (org.eclipse.sdk.ide 3.7.2.M20120208-0800)
To: org.eclipse.sdk.feature.group [3.7.2.r37x_v20111213-7Q7xALDPb32vCjY6UACVPdFTz-icPtJkUadz0lMmk4z-8]


I really don't know what is going on, but I want to get this to work so badly. Thanks in advance for everyone's support!

Answer

From the error message it looks like you are using Eclipse 3.7 (which is about 2 years old at the time of writing this answer).

EGit 3.0 requires at least Eclipse 3.8.2 or Eclipse 4.2.2, see What versions of Eclipse does EGit target? in the FAQ.

So the solution is to upgrade to a recent version of Eclipse, see Eclipse downloads.