Ivan Baidakou Ivan Baidakou -3 years ago 122
Perl Question

Does AnyEvent work with perl 5.26?

I've met the following error::


Can't use an undefined value as a subroutine reference at /home/basiliscos/perl5/perlbrew/perls/perl-5.26.0/lib/site_perl/5.26.0/x86_64-linux/AnyEvent/Loop.pm line 248


when I run my program under perl 5.26.0, meanwhile under 5.20.3 it runs fine.

Any ideas where I should dig to?

Answer Source

Okay, the issue seems in the EV dependency; it should be optional, but installing it solves the problem. I hope it will be useful for somebody.

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download