Puvanarajan Puvanarajan - 5 months ago 1616
Swift Question

Xcode 8 Pod update issue - Re-creating CocoaPods due to major version update

I installed the latest version Xcode 8 beta. My Project was developed by Swift 2.0. So I convert the project to Swift 3. So I update the pod file. But When I update the pod file I am getting error.

Pod file:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

pod 'Alamofire', '~> 3.4'
pod 'SwiftyJSON', :git => 'https://github.com/SwiftyJSON/SwiftyJSON.git'
pod "SwiftSpinner"
#pod "AFNetworking", "2.5.0"
pod 'HanekeSwift'


Error message:


Re-creating CocoaPods due to major version update. Analyzing
dependencies [!] The dependency
Alamofire (~> 3.4)
is not used in
any concrete target. The dependency
SwiftyJSON (from
https://github.com/SwiftyJSON/SwiftyJSON.git
)
is not used in any
concrete target. The dependency
SwiftSpinner
is not used in any
concrete target. The dependency
HanekeSwift
is not used in any
concrete target.


NOTE:
I already update the cocoapods using this command

sudo gem install cocoapods

Answer

To solve this issue delete the current pod file and create one using the terminal. Follow the below steps:

  1. Open Terminal
  2. Navigate to your Project Path
  3. Type pod init in terminal to create new pod file
  4. Open the newly created pod file and write the pod line which you want to install after target "TargetName" do and before end.
  5. Then type pod install in the terminal

Hope this helps!

Comments