code.prio code.prio - 24 days ago 6
Ruby Question

Error with Gem installtion in Windows system

I am using a Windows PC running 8.1 and working with Ruby Installer 2.1.5.

While installing a gem I am getting a error:

C:\Users\***>gem install bundle
ERROR: Could not find a valid gem 'bundle' (>= 0), here is why:
Unable to download data from https://rubygems.org/ - SSL_connect retur
ned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed (
https://api.rubygems.org/latest_specs.4.8.gz)


I hope there is a good solution.

Answer

I had this problem too. But using the older version is not the proper solution.

Here is the two solution help to fix this certificate error

1. Using the http instead of https will allow you to install the gem without that error

gem install bundler -r --source http://rubygems.org/

2. Update the certificate based on the solution provided in the below link

https://gist.github.com/luislavena/f064211759ee0f806c88

Comments