Coming from a C# background the naming convention for variables and method names are usually either CamelCase or Pascal Case:
// C# example
string thisIsMyVariable = "a"
public void ThisIsMyMethod()
# python example
this_is_my_variable = 'a'
See Python PEP 8.
Function names should be lowercase, with words separated by underscores as necessary to improve readability.
mixedCase is allowed only in contexts where that's already the prevailing style
Use the function naming rules: lowercase with words separated by underscores as necessary to improve readability.
Personally, I deviate from this because I also prefer
lower_case for my own projects.