Loren Loren - 1 month ago 12
Android Question

Making android app compatible with Kitkat and above versions

I am new to android . I want to have an app does gives backward compatibility also means it should support versions from kitkat and above. If I make Project build target(Properties --> Android) to Android 5.0 (API-21) then it means it will run in lollipop only? If I want to add support library then which library should I import right now I have seen people importing appcompat v7 library for lollipop development. I know this one is quite basic question.

Answer

Just write Minimum sdk version in your manifest file

<uses-sdk
        android:minSdkVersion="19"
        android:targetSdkVersion="21" />

Just set minSdkVersion and targetSdkVersion in app gradle file.

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "guard.proguard"
        minSdkVersion 19
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }

}
Comments