Bhumit Mehta Bhumit Mehta - 1 month ago 11
iOS Question

The document Main.storyboard requires Xcode 8.0 or later

I downloaded Xcode beta and opened my existing project to see how it works with Xcode 8 beta (I opened Storyboard file from Xcode 8).

Now when I open my project from Xcode 7.3 I am not able to open storyboard file , it gives me following error


This version does not support documents saved in the Xcode 8 format.
Open this document with Xcode 8.0 or later.


Xcode 7 error
What should I do to revert back, as I want to continue working on Xcode 7.

In Xcode 8 I was prompted to select device and I selected iPhone 6S, I think that part is somehow responsible for storyboard file not opening in Xcode 7

Answer

I have figured it out. I opened Storyboard in Xcode 8

Open Interface Builder Document and select opens in Xcode 7.x instead of Latest Xcode (8.0) as in following screenshot

enter image description here

On doing this, you will get an alert saying "Saving for Xcode 7.x will close your document and data for Xcode 8.0 features will be removed."

Click Save and Close and you will be able to open storyboard in Xode 7.x.