oviroa oviroa - 4 years ago 380
Android Question

Attempting Firebase auth (with Google) on Android Wear 2.0 shows "InternalFirebaseAuth.FIREBASE_AUTH_API is not available on this device"

I am trying to use Firebase Auth (10.0.1, Google as auth provider) with Android Wear 2.0, but when I run signInWithCredential, operation fails (see this logs below.) I am using this method.

com.google.firebase.FirebaseApiNotAvailableException: API: InternalFirebaseAuth.FIREBASE_AUTH_API is not available on this device.
at com.google.firebase.zza.zzz(Unknown Source)
at com.google.android.gms.internal.zzzq$zzd.zzy(Unknown Source)
at com.google.android.gms.internal.zzaap$zza.zzC(Unknown Source)
at com.google.android.gms.internal.zzaap$zza.onConnectionFailed(Unknown Source)
at com.google.android.gms.internal.zzaap$zzb$1.run(Unknown Source)
at android.os.Handler.handleCallback(Handler.java:751)
at android.os.Handler.dispatchMessage(Handler.java:95)
at android.os.Looper.loop(Looper.java:154)
at android.os.HandlerThread.run(HandlerThread.java:61)


I have been successful using Firebase Real Time DB with Wear 1.0 and 2.0, but auth is not cooperating. Any ideas?

Answer Source

I notice you asked this same question on the Wear developer community on G+, and got the answer there: Firebase Auth is not yet supported on Wear. https://plus.google.com/+LewisMcGeary/posts/BQzGE2G4RX6

Recommended from our users: Dynamic Network Monitoring from WhatsUp Gold from IPSwitch. Free Download